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Using the Firefox Internet Browser

What is Firefox"?

Firefox" is an open source Internet browser developed by the Mozilla Foundation based
on the code released by Netscape. Open source is a model of software development that
allows a product’s code to be freely available to view and modify, usually with the
expectation that any changes made will be given back to the community for its use. This
permission to view and change code allows those with interest and skill in the product to
contribute changes. This allows any Firefox user to develop new features for the browser
and share them with any interested party.

The main difference between Firefox and the Mozilla Suite is that Firefox is a web browser only.
Whereas, the general term "Mozilla" refers to a combination of browser, email client, and HTML
editor.

Firefox automatically disallows pop-ups and spyware, features a customizable interface, tabbed
browsing windows to reduce clutter, integrated security features, useful printing features, and an
interactive Find feature.

Opening Firefox

To launch the Firefox Internet browser, either: {':)
e Double click the Mozilla Firefox shortcut icon on your desktop. — OR - 7]
e Click the Start button, then Programs, then the Mozilla Firefox folder, and  EREEIEIEEEE

finally the Mozilla Firefox icon.

Navigating Web Pages

Following Links

When you launch Firefox, you are brought to the SJIC web site (www.sjcny.edu). This is referred to as
your Home Page. When viewing a web page you can scroll up and down to read text and view images.
If you see a link to something else that interests you, you can left-click to follow it. Most links are a
distinctive color and underlined. However, any time you move your cursor over something (text

or an image) and it becomes a pointing hand, you have found a link. ﬁl

Generally, links you have visited will change color (most sites use the standard coloring blue for
unvisited links and purple for visited links).

Location Bar
The Location bar at the top of the browser window shows the URL (web page address) of the site
you're viewing. You use the Location bar to enter in a web site address for a different site. To go to a
particular web site, follow these steps:

1) Click once on the address currently visible in the Location bar.

2) Press the delete key on your keyboard.

3) Type in the URL of the web site you'd like to visit.

4) Press the enter key on your keyboard.

TIP: Click the down-arrow on the far right of the Location bar to see a list of all URLs you have typed
in (not sites you have visited, only the ones you have typed in yourself).
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Toolbar Buttons
If a web page did not load correctly or completely, or if you suspect you are not looking at the most
recent page content, you should click the Reload button to refresh the contents of that page.

Once you have visited a few web sites, you can navigate backwards through visited web pages by
clicking the green left arrow on the Firefox Navigation toolbar (see Figure 1). If you back up too far,
click the green right arrow on the toolbar to move forward. To back up or go forward more than one
page, click the drop-down arrow next to either arrow button to get a list of sites to choose from. You
can also right-click either button to see a list of pages you've visited during the browsing session.

The button that looks like a house will always take you back to your home page. Use the button that

looks like a printer when you need to print web pages (see the related section later in this manual). If
the page is taking too long to load, you can stop the process by clicking on the Stop button. Sometimes
a page will load faster on the second or third try. Press the Reload button to try loading the page again.

Reload Stop Location bar Search bar

|/ | \

‘<::| - |:> - @ @ .__E"{@ hikkpe: f v, sjcry eduf # Ilg'

Pxx /

Back Forward Home page Print Recently entered URLs

Figure 1: The Firefox Navigation toolbar.

Tabbed Browsing

Firefox uses a feature known as Tabbed Browsing to allow multiple browser sessions to be opened
and manipulated within the same Firefox window. This frees up space on your Windows taskbar and
allows you to browse many sites conveniently from within one Firefox window. You don't have to use
tabbed browsing, but if you do you might find tabbed browsing is a better, faster way to browse the
Web.

Opening Tabs
To work with tabbed browsing, follow these steps:
1) Open the Firefox browser. The SIC web site appears.
2) To open a new tab, press CTRL+T or select File=>New Tab.
3) Type in the URL of the web site you'd like to visit in the Location bar and press the Enter key
(type in www.yahoo.com for practice purposes).
4) You will see 2 two tabs located just below the browser's toolbar and Location bar (see Figure
2). One has a SJC title and the other has the title of the page you are visiting. You can easily
move between the two web sites by simply clicking the appropriate tab.

- [, 4
\JIZI - |_L,' - @ nﬁl I v your-web-site-address-here, org

@ gk, Joseph's College - Mew York | | {Untitled}

Figure 2: Two open tabs below the Navigation bar.

G
¥ | TIP: After typing in a URL in the Location bar, press ALT+Enter to open the address in a new tab.
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Moving Tabs Within a Window

Tabs are displayed in the order you open them, which may not always be what you want. To move a

tab to a different location within a Firefox window, simply drag it there using your mouse. While you
are dragging the tab, Firefox displays a small indicator (usually a purple down arrow) to show where
the tab will be moved (see Figure 3).

L
@ St. Joseph's College - Mew York | &P ahoo! k

Figure 3: The purple arrow indicates a new tab location.

Closing Tabs

To close the current tab, press Ctrl+W, click the Close Tab button = on the right side of the browser
window or select File=>Close Tab. To close all tabs other than the current one, right-click on any tab
and choose Close Other Tabs.

wihat

Loading Links in Tabs and Other Options Campl EE: t::t :; :ZK :—:Eduw
You can easily load any link found on a web page in its own Camp! = L
tab. When you locate the link on a page (when the mouse Liturg  Bookmark This Link...
arrow changes to a hand) right-click the link and choose student  2OvElinkAs..
Open in New Tab from the context menu (see Figure 4). crochrr I
Find a link on the SJC web site and try right-clicking it to cAp | Copy Link Location
open in a new tab. crudem ud  ErOpettes

T e Open Link Target in IE

Figure 4: Right-click a link to open in a new tab.

There are other ways to control how tabs work. If you right-click on a tab, fien Tab

you will see a context menu (see Figure 5). Here you're able to create new Beioad Tab
tabs, reload the current tab, reload all tabs, close other tabs, bookmark the tab Reload &l Tabs

. l Other Tabe
(see page 6) and finally close the selected tab. i
Bookmark, This Tab. ..

Bookmark all Tabs. ..

Close Tab

Figure 5: Right-click a tab to
view these options.

Adjusting Tab Open Options

You can control how Firefox opens tabs using the options Open links from other applications in:
found under Tools=>Options and then the Tabs heading at LR
the top of the dialog box. You can open links from other 9 vty el o e el rgantt s Ll
applications in a new window or a new tab in the most recent @ tie st [eren: Gyt
window (see Figure 6). Additionally, you can force links that || & earee finks that apen new windows ko open in:
open new windows to open in a new tab. For example, if you W s e eyl s M Tl
are reading a message in your Webmail account and you = apew tab
click a link in the e-mail, Firefox will then launch the link in ¥ Hide the tah bar when only one web site is open
a new tab in the same window. ¥ Select new tabs cpened From links

[~ warn when closing multiple tabs

Figure 6: Tab options
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Using the Firefox Internet Browser

Bookmarks

Bookmarks provide a permanent way to remember and store web pages you find useful or refer to
often. Other Internet browsers may refer to them as Favorites. The sections below will help you add,
delete, view, rename and organize Firefox bookmarks.

Adding

You can add a web page to your Bookmark list using one of three easy methods:
e To bookmark a web page, right-click on the page and choose Bookmark This Page.
e Click Bookmarks—>Bookmark This Page from Firefox's menu bar (see Figure 7).
e Use the keyboard shortcut CTRL+D.

Bookmarks  Tools  Help

Bookmark This Page... Ckrl4D k
Manage Bookmarks. ..

rs.nek

Figure 7: The Bookmarks menu option.

No matter which method you choose, you'll be prompted to either keep or change the bookmark name
and choose its location (see Figure 8). By default, the page will be saved in the Bookmarks folder. This
list will appear in the drop-down menu when you click Bookmarks from the menu bar. Click the OK
button to save the site as a bookmark.

Add Bookmark x|
Mame; I Enter the bookmark name here
Create in: I ~) Bookmarks d |
(04 Zancel |

Figure 8: The Add Bookmark dialog box.

Let's practice adding bookmarks:
1) Go to the main SJC web site (type in www.sjcny.edu in the Location bar or click the Home
button on the browser's toolbar).
2) Use one of the three methods listed above to add the bookmark.
3) Keep the suggested bookmark name and leave the Create in folder as Bookmarks.
4) Click the OK button to finish.
5) Repeat these steps to add a second bookmark of your choosing.

Viewing
To view the list of your stored bookmarks, simply click the Bookmarks menu and browse the list.
Left-click once on the name of the bookmark to visit a stored site.

Deleting
You can quickly delete a bookmark from your list by following these steps:
1) Click the Bookmarks menu.
2) Scroll the list to locate the bookmark you want to delete.
3) Right-click the name of the bookmark and choose Delete from the context menu that appears.
Once deleted, the bookmark cannot be retrieved.

St. Joseph’s College 6
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Organizing Using the Bookmarks Manager

Firefox's Bookmarks Manager is a very useful tool for working with your saved bookmarks. It allows
you to rename, rearrange, sort, edit and import/export bookmarks. Open up the Bookmarks Manager
window by going to Bookmarks—>Manage Bookmarks.... The Bookmarks window displays
bookmarks and folders in a list (see Figure 9). The bookmark names are the same ones that appear in
the Bookmarks menu. The following picture is of the Bookmarks Manager window.

) Bookmarks Manager

File Edit  Wiew

Mew Bookmark.,. Mew Folder,.. Mew Separator | Move... Properties..., Rename...

Search: |— ) B _|
lwal

=l | Bookmarks | | Mame Location Diescription
[Ex W=l ST 1Y [ Bookmarks Toolb, ., &dd bookmarks to this Folder £,
|7 Quick Se... ;
[#-| ] Firefox a... | |# | Quick Searches Handy searches that can be p...
[# | Firefox and Mozl ..
|| MSM.com hikkps e, microsoft, cam) .
| | Radio Station Guide hEkp: S, microsoft, com/...

i objeckis)

Figure 9: The Bookmarks Manager window.

Setting Up Bookmark Folders
Setting up folders to store your bookmarks is easy.
1) Click the New Folder button on the Bookmarks Manager toolbar or choose File=>New Folder.
2) Enter a folder name in the Name field and if necessary, add a short description of the folder
contents in the Description area (see Figure 10).
3) Click the OK button when finished.
4) For practice purposes, create two folders: one called SJC Links and the other Useful Links.

Properties for “New Folder™ El

Mame: I Folder Mame Here

Description: | envey & short description of the contents of

the Folder here.|

K Zancel

Figure 10: The folder properties dialog box.

) . . . . .
{ TIP: If you don’t see a toolbar in your Bookmarks Manager window, simply click the View menu and
then choose Toolbar.
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Moving Bookmarks
You can rearrange bookmarks, or place them into folders, by using the Move button.
1) Click the St. Joseph's College bookmark in the Manager window. @
2) Click the Move button on the Bookmarks Manager toolbar or choose Mave, ..
Edit->Move Bookmarks.
3) Inthe window that appears, click the newly created SJC Links folder and then click the OK
button to move the bookmark into the folder.

Renaming Bookmarks
You can rename a bookmark in your list by using the Bookmarks manager.
1) Click the St. Joseph's College bookmark.
2) Click the Rename button on the Bookmarks Manager toolbar.
3) Inthe bookmark properties dialog that appears (see Figure 11), either add to the existing name
or delete it and enter a more descriptive name that easily identifies the bookmark.
4) Click the OK button when finished.
5) For practice purposes rename the St. Joseph's College — New York bookmark to SJC Web Site.

Properties for "St. Joseph's College |
harme: I Sk, Joseph's College - Mew Yark,
Location: I hikkp: f funan, sjcry . eduyf
Keyword: I
Description:

[ Load this bookmark in the sidebar

Zancel

Figure 11: The Properties dialog box for a particular bookmark.

Searching for Bookmarks
As you continue to store bookmarks and the list grows, it can be more difficult to locate ones you need.
Using the Bookmark Search bar, you can quickly narrow down long lists of bookmarks to locate just
the ones you need to view at a given moment.

1) Enter a search term or keyword in the Search bar located just under the Bookmarks Manager

toolbar (see Figure 12).
2) Firefox displays just the bookmarks that contain the keyword or phrase in the Name field.
3) Delete the search keyword or phrase to display all of your bookmarks.

il = g (0 s
L I il v £~
Mew Bookmark,., Mew Folder.,, Mew Separator Move. ., Properties.., Rename...
Search:

Figure 12: The Bookmark Manager Search bar.
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Closing the Bookmark Manager
When finished with the Bookmark Manager window, close it by clicking File->Close or by clicking
the X in the right corner.

Using Tab Groups
There are two ways to use the Tab Groups feature in Firefox: open all bookmarks stored in a
particular folder in separate tabs or open multiple tabs and save them all as a group (bookmark folder).

Method 1: After adding bookmarks to a bookmark folder view the contents of the folder in the
Bookmarks menu (for example, the SJC Links folder). The bookmark folder contents are displayed,
along with an additional item at the end named Open in Tabs (as shown in Figure 13). When you
select Open in Tabs, all the bookmarks in that folder are opened in individual tabs. Keep the number of
bookmarks in a folder that will be opened as a group to a manageable number—say, fewer than five.

=TT - * i, |
B 51C Links 3 B 51 web site
& 5t. Joseph's Callege - New Yark B 510 WEEMAIL
NEW YORK © W/

Dpen in Tabs

il
Figure 13: Opening a tab group menu option.
Method 2: The other method of using Tab Groups requires that you open multiple tabs and load a web
site in each one. This is really useful if, for example, you are researching a particular topic and you
have several tabs open that each contains something relevant to your research. Rather than bookmark
each tab individually, you can create a group (folder) to store all of the open sites for quick referencing
later.
1) Press CTRL+T three times to open three new tabs.
2) Enter in a web site URL in each of the three tabs and press the Enter key to load each one.
3) To save all open tabs as one tab group (essentially a bookmark folder) either click
Bookmarks—>Bookmarks All Tabs... or use the keyboard shortcut CTRL+SHIFT+D.
4) In the dialog that appears (see Figure 14) remove the [Folder Name] and replace it with a more
relevant bookmark folder name.
5) Click the OK button when finished.
6) Click the Bookmarks menu option and look for the newly created folder name. All of the
saved links are contained in the folder.

Mamne:! I [Folder Mame]|

Creake in: I ~) Bookmarks j |

(0] 4 Cancel |

Figure 14: The Bookmark All Tabs dialog box.

Using the Sidebar

Firefox can be used with the Sidebar displayed on the left side of the browser window. It contains
either your web page History list or your Bookmarks. To display the Sidebar, click
View->Sidebar->History (or Bookmarks) or use the keyboard shortcuts CTRL+B to display
Bookmarks or CTRL+H to display History.

St. Joseph’s College 9
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Using the Searchbar
Firefox has simplified Internet searching by integrating a web search feature directly into the browser.
Though the primary engine used by this search tool is Google, other engines can be used as well.

To search for a web page, type the text to search for in the Google Search Bar [ L
at the top right corner of the browser window and then press the Enter key. A =
Google results window will open. (Gl Google
| "7 Yahoo
You can also perform web searches using the additional search engines such as | & amazaon.cam
Yahoo.com, Amazon.com and Answers.com. To change search engines, click
the small black down arrow to the right of the currently selected search engine
icon (as shown in the red box in Figure 15). Click the engine you want to
substitute. The symbol for that search engine will now replace the Google
symbol in the Searchbar, indicating that it is now the active search engine. Then, ] Erlies g

A= Answers.com
@ Creative Commaons
Y eBay

enter your search term(s) and press the Enter key.
Figure 15: The Search Bar

To clear the search history right-click in the search bar area and choose Clear Search History.

Finding Text on Web Pages

If you want to search for a particular word or phrase within a web page, go to Edit=>Find in This
Page or use the keyboard shortcut CTRL+F. The Find toolbar appears at the bottom of the screen (see
Figure 16). Type in the text you want to search for in the white box. As you type, Firefox highlights,
and jumps to, the first instance of the search term on the page. To find the next instance of your search
term, click the Find Next button. If Firefox does not find the text in the current page, the background
of the text field will turn red and an alert appears in the Find toolbar indicating the phrase was not
found.

El Find: ) Find Mext &) Find Previous =] Highlight [] Match case

Figure 16: The Find toolbar

While searching for a text string, choose from the following search choices as found on the Find
toolbar:

e Find Next (or CTRL+G): find text in the page that is below the current cursor position.

e Find Previous: find text that is above the current cursor position.

e Highlight: highlight occurrences of your search string in the current page.

e Match case: limit the search to text that has the same capitalization as your search string.

TIP: Firefox allows you to search for words you select within a web page:

1) Select (highlight) any words in a web page.

2) Right-click and choose "Search Web for [your selected words]" from the menu. Firefox opens a
new tab and uses your default search engine to search for your selected words.

To practice finding text on a web page, follow these steps:
1) Go to the SJIC home page and click Edit=>Find in This Page.
2) Inthe find text box enter the word college and click the Find Next button. The first instance of
the word on the page is located and highlighted. Click the Find Next button again to locate the
second instance. Click the Close button (small orange x) to close the Find toolbar.

St. Joseph’s College 10
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Printing Web Pages

Page Setups

To customize how pages are printed in Firefox, you can use Page Setup. When viewing a web page,
click File->Page Setup. In the Format & Options tab (see Figure 17) you can choose page orientation
(portrait or landscape), scale or have pages shrink to fit page widths automatically. In the Margins &
Header/Footer tab (see Figure 17) you can adjust printed page margins, as well as choose what you
want or don't want included in the headers and footers (title, page numbers, date and time, etc.).

Format & Options | MMargins & Header/Fooker | Format & Options  Margins & HeaderFooter: |

~ Formak ~ Margins {inches)

r ILLandscape Top: ID'5

Orientation:  {#

Scale: |a|:| 4% [V Shrink To Fit Page Width Left: E ¢+ Right:

~ Dpkions

™ Print Background {colors & images) :._ [ :

~ Headers & Footers

| Title )| blank- =] | uRL =l

Left: Center: Right:

I Page # of # j I --blank-- j I DateTime j

(04 I Cancel | (0] 4 I Cancel |

Figure 17: The Page Setup dialog boxes (use the 2 tabs at the top).

Print Preview
To have an early peek at how a page will look before it is printed, you can use Print Preview. When
viewing a web page, click File->Print Preview. To close the preview simply click the Close button.

In Print Preview, you can use the following features on the preview toolbar (shown in Figure 18):

e View a preview of each page: Click the Next, Previous, First, or Last arrows to move between
pages.

e Change the scale (size) of pages: In the Scale drop-down menu, choose any amount from
"30%" of the original size to "200%" to vary the amount of information on the printed page. To
automatically resize pages so that they fit the width of the paper, choose "Shrink to Fit". You
can also type in your own percentage by choosing "Custom...".

e Change the orientation of the page: Choose Portrait to position the page with the shorter side
facing up. Choose Landscape to position the page sideways with the longer side facing up.

e (o to Page Setup: Click the Page Setup button to further customize pages you want to print.

e Go to Print: Click the Print button to print the pages.

‘ Prink. .. | Page Setup... | Page: |4 4 |1 of 3 p M | Siale: IShrinkTu:u Fit "l H (2] Portrait k] Lanl:lscape| Close | ‘

Figure 18: The Print Preview toolbar
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Printing Only a Portion of a Page

You can print only a portion of a web page (for example, a paragraph it range

from a lengthy page) using the steps listed below: e al
1) Select (highlight) the portion of text in the current page you
would like to print. " Page:  from: |1 t|:|:|1

2) Click File>Print. The print dialog box will appear.
3) Under the Print Range area, click Selection (see Figure 19).

f* Selection

4) Click the OK button to print. Figure 19: The Print Range area of the

Print dialog box.

Open Other File Types in Firefox

When opening files from within Firefox (Word or Excel documents for example) you may notice that
Firefox handles these requests slightly different than other browsers. You can control the behavior of
file downloads by using either the left or right mouse buttons to obtain the files. There is no trick to
downloading files, but you should be aware of what happens on screen when you attempt to grab a file
sent via e-mail attachment in your SJC Webmail account or one you find on a web site.

Using the Right-Click Method (Saving Attachments)
To download and save a file attachment you receive in an e-mail message in your SJC Webmail
account, without opening the file, follow these steps:

1) Right-click either the file link towards the bottom of the e-mail or the paper clip icon.

2) From the context menu that appears, click "Save Links As..." (see Figure 20).

File: Frea lunch dnc iMKhwtos)
Cpen Link in Mew Window

Open Link in Mew Tab

gt Unread || Re| Bookmark This Link. .. war
k to InBux”M Save Link As. .. % s Un
Send Link. ..

Zopy Link Location

to... | | bdowe to.

Propetties

+  2pen Link Target in IE

Figure 20: The right-click menu option for a file
attached to an e-mail.

3) Inthe Save As dialog box that appears, browse to the folder or drive location where you'd like
to save the file and click the Save button.

Using this method, you can open the saved file outside of Firefox whenever you want. The file is only
copied from the original e-mail message; it is not removed.

St. Joseph’s College 12
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Using the Left-Click Method (Viewing Attachments)
To download and open a file attachment (directly from within Firefox ) you receive in an e-mail
message in your SJC Webmail account, follow these steps:
1) Left-click either the file link towards the bottom of the e-mail message or the paper clip icon.
2) Inthe dialog box that appears (see Figure 21), click the radio button next to the option "Open
with" and then choose the appropriate program in the drop down list to the right. For example,
if the file you are trying to open is a document, choose "Microsoft Word for Windows" in the
drop down list.

‘fou hawve chaosen ko open

@ Free Lunch.doc

’ whichiis a: Microsoft Word Docurnent
Fram: htkp: ffwebmail, sicry, edu

~ w'hat should Firefox: do with this file?

A 4
Microsaft Waord For Windows {default) j

{~ Save to Disk

[ Do this autamatically For files like this From now o,

oK I Cancel

Figure 21: The Open file attachment dialog box.

3) Click the OK button.
4) To save the attachment from within the associated program simply click File->Save As and
then browse to the folder location where you want to store the file (My Documents folder, etc.).

! NOTE: The following items may or may not display depending on your browser's tab and download
settings.

At this point, you may notice several changes in your screen view of Firefox. Firefox will briefly
display the file attachment in the appropriate program. Then, this application is usually automatically
minimized to your Windows Taskbar. Within a few seconds, the Downloads Complete window
appears in the lower right corner of your screen with an indication that the download has completed
(see Figure 22). This popup will disappear after a few seconds.

Downloads Complete
&ll Files have finished downloading,

Figure 22: The Downloads Complete popup.

You may notice a dialog box on screen after downloading the file. A Firefox Download Manager
window appears if the option to "Close the Download Manager when all downloads are complete” box
is unchecked. This option can be checked or unchecked when found under Tools->Options, then the
Downloads button at the top. If necessary, you can simply close the dialog box using the black X in
the upper right corner of the window.

St. Joseph’s College 13
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Using the Firefox Internet Browser

Additionally, you may have an extra empty tab or Firefox window open. The title of the tab or window
may appear as "Untitled". If a new tab appeared, simply close it using the small x in the orange square
at the end of the tab bar (or right-click on Untitled and choose Close Tab in the popup menu).

|| {Untitled) %

Figure 23: The close button at the right end of the tab bar.

If a new window appeared (you will see an extra Mozilla button at the bottom of your screen in the
Windows Taskbar) click the black X in the upper right corner of the window to close it.

Keyboard Shortcuts

The table listed below contains some of the more useful keyboard shortcuts for Firefox.

Common Keyboard Commands for Firefox

Press this

Ctrl+D
Ctrl+B
Ctrl+W
Ctrl + C
Ctrl+V
Ctrl + F
Ctrl+P
Ctrl+ A
Ctrl+T
Ctrl + Tab
Ctrl+ L
Ctrl+ K
Ctrl + -
Ctrl + +
Alt + Enter
Esc
Backspace
Shift + Backspace
End

Home

F11

F1

F5

To do this

Add a bookmark

Open Bookmarks in the Sidebar

Close a tab

Copy

Paste

Find on this page

Print

Select all items on a page

Open a new tab

Move to the next open tab

Select the Location bar

Perform a web search using the Searchbar
Decrease page text size

Increase page text size

Open a web site URL in a new tab (after typing the URL into the Location bar)
Stop loading a page

Move back a page

Move forward a page (after moving back a page)
Go to the bottom of a page

Go to the top of a page

Full screen

Help

Reload a page
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