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CCrreeaattiinngg  aa  GGrraaddee  BBooookk  

Excel is a great application to use to track student grades throughout the semester. One of the main 

advantages of creating a computerized grade book is that Excel can perform calculations for you. 

Additionally, Excel can automatically assign a letter grade to a column of numbers, such as a final 

grade column. An Excel grade book can be easily reused from semester to semester by simply 

removing student names and grades; not the formulas used for calculations. All these benefits help 

make an Excel grade book a much better choice than working on paper. 

 

SSaammppllee  LLiisstt  ooff  SSttuuddeennttss  

In the example used throughout this manual (see Figure 1), we are working with a grade book for a 

class that has 3 homework assignments, 2 projects, 3 tests, and a final. We will compute each student's 

class average before the final exam. Then, the final grade is computed after taking the final exam and 

the matching letter grade is recorded. 

 

The examples provided throughout the manual may have to be adjusted to fit your grading needs. 

Please feel free to contact one of the TIS trainers if you need assistance setting up your Excel grade 

book. Before continuing through the rest of this manual, create a spreadsheet to use for practice. Use 

the example listed in Figure 1. 

 

 

The breakdown of the final grade is computed as follows:   

 

 

 

 

 

 

 

1) Enter the assignment labels and percentages listed above into the Excel 

worksheet beginning in cell A15.  Type in the numbers beginning 

with a decimal point.  
2) For the Total, use the sum formula to sum cells B15 through B18. 

3) To display the percentages with the percent sign, select cells B15 

through B19.  On the Home tab, in the Number group, click the Percent 

Style button (see Figure 3). 

Figure 1: Sample list of students used for tracking grades. 

Figure 3: The Number 
group on the Home tab. 

Figure 2: Sample 
assignment weights. 
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GGrraaddiinngg  FFoorrmmuullaass  

The types of formulas used for grading purposes include (but are not limited to): summation, average, 

and multiplication using percentages. Additional formulas may be use to find the median, minimum or 

maximum numbers in a range of scores. Using our sample data, we will calculate: 

 The students' class average before the final exam. 

 The students' class average after taking the final exam. 

 The students' letter grade based on their numerical final grade. 

 

Computing the Class Average Before the Final Exam  

This grade is calculated by adding the following three items: homework average multiplied by the 

homework %, project average multiplied by the project % and the test average multiplied by the test 

%.  The result is multiplied by 100, then divided by the sum of the homework, projects and test % (this 

is to compensate for the missing 25 percent that we don't have yet for the final grade). The result is 

divided by 100. To calculate the students' class average before the final exam, follow these steps: 

 

1) In cell L1 and type in the heading Class Average. 

2) In cell L2 enter the following formula (see Figure 4 for an explanation of the formula): 

 

=(AVERAGE(D2:F2)*$B$15+AVERAGE(G2:H2)*$B$16+AVERAGE(I2:K2)*

$B$17)*100/($B$15+$B$16+$B$17)/100 
 

3) Press the Enter key to accept the formula. If you used the sample data listed in Figure 1, the 

result should be 88.73333333. 

 

Instead of typing in the actual percentages and grades into the formula, we are using what is called cell 

referencing. We enter specific cell addresses in the formula so Excel knows where in the worksheet to 

go to get the numbers.  

 

Figure 4: An explanation of each part of the lengthy formula used to calculate the students' 
average before the final exam. 



Microsoft Office Excel 2007 ï Grade Book 
 

 

St. Josephôs College   3 

Technology & Information Services 

Figure 6: Computed columns using the sample 
student data. 

When grades are referenced in the formula, we use relative cell referencing. Relative cell referencing 

allows the formula to change row numbers as the formula is copied down the column.   

 

When the weighted values (percentages found in the range from B15 to B18) are referenced in the 

formula, we use absolute cell referencing. This prevents the cell address from changing when the 

formula is copied. To do this we place a dollar sign in front of the column letter and row number. 

Then, we can take this formula and copy it to a new cell location for each student. Excel changes only 

the relative cell addresses to reflect the new location.  

 

To copy this formula down the Class Average column, follow these steps: 

1) Click on cell L2. This is the cell where the first computed class average was 

entered. 

2) On the Home tab, in the Clipboard group, click the Copy button or use the 

keyboard shortcut Ctrl+C. 

3) Select the remaining empty cells in the Class Average column that 

correspond to each student (see Figure 5). 

4) On the Home tab, in the Clipboard group, click the Paste button or use the 

keyboard shortcut Ctrl+V. All references to row 2 are changed to row 3, row 

4, etc., but the references to the weighted values (percentages found in the 

range from B15 to B18) are kept static. 

 

 

Computing the Final Grade 

The final grade is calculated by first adding the three weighted percentages (B15 homework, B16 

projects, and B17 tests), then multiplying that total by the class average. Next, multiply the final exam 

score by the final exam weighted percentage. Finally, add the two numbers left as a result of the 

calculations. 

 

1) In cell M1, type the heading Final Exam. 

2) Enter in all student final exam scores beginning in cell M2 and continuing down the column to 

the last student record. For practice purpose in the sample student list, enter the following 

grades:  89, 92, 84, 87, 72 

3) In cell N1, type Final Grade. 

4) In cell N2, type in the following formula:  =(L2*($B$15+$B$16+$B$17))+(M2*$B$18) 

5) Press the Enter key to accept the formula. If you used the sample data listed in Figure 1, the 

result should be 88.8 for the first student. 

6) Copy the formula down the column. Columns L, M, and N should look similar to the ones 

listed in Figure 6. 

 

Figure 5: Select cells 
where you will paste 
the formula.  
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Assigning Letter Grades Using a Lookup Formula 

Excel can automatically assign a letter grade for students based on a numerical final grade by using a 

Lookup function.  The lookup first examines the final grade for the student listed in the N column. 

Then, that grade is located in the list of numerical grades stored in the lookup table off to the side of 

the sheet (the R column). When the numerical grade is located between two numbers, Excel returns the 

letter grade (found in the S column) for the lower number in the range. For example, if a student's final 

grade is a 91, their letter grade is an A- because a 91 falls below the number required for an A (93).  

 

The formula syntax for the Lookup function is as follows: 

=Lookup(value to look up, columns and rows to look in, item to place in cell) 

 

1) In cell O1, type the heading Letter Grade. 

2) Starting in cell R2, enter the numerical grade scale listed in Figure 7.   

3) Starting in cell S2, enter the corresponding letter grades listed in Figure 7. 

These two columns together frame the Lookup Table. 

4) In cell O2, enter the following formula:  

 

=LOOKUP(N2,$R$2:$R$13,$S$2:$S$13) 

 

5) Press the Enter key to accept the formula. If you used the sample data listed in 

Figure 1, the result should be B+ for the first student. 

6) Copy formula down the column to the last student record. 

 

Student letter grades always refer to the lookup table. If you update the grade range, 

the student letter grades automatically are updated to reflect the change. 

 

 

FFoorrmmaattttiinngg  CCeellllss  

To add some visual appeal to the grade book and to highlight areas of the grade book you can use any 

combination of formatting features found in Excel 2007. For example, you may want to add a border 

or shading to a range of cells, change the formatting used to display numbers or percentages, display 

gridlines or column headings, or add a sheet header or footer. 

 

Working with Borders 

There are many different types of cell borders and colors you can apply. After working with the basics 

steps listed below, experiment with borders until you achieve the desired sheet appearance.  

 

To add a border to a cell, follow these steps: 

1) Select the cell(s) to which you want to add a border. 

2) Click the arrow to the right of the Borders option found in the Font group on the Home tab of 

the Ribbon. 

3) Choose the appropriate border from the list (see Figure 8). 

Figure 7: Grading 
scale used in lookup 
function. 
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To change the color of a border, follow these steps: 

1) From the Home tab, in the Font group, click the arrow to the right of the Borders option. 

2) In the list of available border formats, point to Line Color and click to select the desired color. 

The cursor changes to the shape of a pencil.  

3) To format individual borders that are already applied to cells, click the borders you want 

changed. To format multiple contiguous cells, click and drag across the desired cells. 

4) To quit formatting border colors, press the Esc key on the keyboard.  

 

To change the line style of a border, follow these steps: 

1) From the Home tab, in the Font group, click the arrow to the right of the Borders option. 

2) In the list of available border formats, point to Line Style and click to select the desired style. 

The cursor changes to the shape of a pencil.  

3) To format individual borders that are already applied to cells, click the borders you want 

changed. To format multiple contiguous cells, click and drag across the desired cells. 

4) To quit formatting border line styles, press the Esc key on the keyboard. 

 

To remove a cell border, follow these steps: 

1) Select the cell(s) to which you want to remove a border. 

2) Click the arrow to the right of the Borders option found in the Font group on the Home tab. 

3) Choose No Border from the list. 

 

 

Working with Shading 

To highlight certain areas of the grade book, you may want to apply color to a cell or group of cells. 

You can easily remove cell shading if you no longer need it.  

 

To apply shading to cells, follow these steps: 

1) Select the cell(s) to which you want to apply shading. 

2) On the Home tab, in the Font group, click the arrow next to Fill Color. 

3) Live Preview displays a sample of the color choice for the selected cell(s) when you hover the 

mouse pointer over a color in palette. 

Figure 8: The borders option found in the Font group 
on the Home tab. 
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4) Click the color on the palette that you want to apply to the selected cell(s) or choose the More 

Colorsé option to see a larger selection of color choices (see Figure 9). 

 

 

 

 

To remove cell shading, follow these steps: 

1) Select the cells that contain a fill color you want to remove. 

2) On the Home tab, in the Font group, click the arrow next to Fill Color and then click No Fill. 
 

 
 

Number Styles 

Excel provides preset number formats to help you standardize how numbers will appear in your grade 

book. For example, when formatted to show only two decimal places, the class average for the first 

student in the sample database (cell L2) displays as 88.73 and not 88.73333333. When working with 

the sample student database, you may decide to format the numbers in the class average column (L) 

and the Final Grade column (N). Use the steps listed below to format any of the cells in your real grade 

book. 

 

When you need to format numbers quickly, use the options on the Ribbon. To see all available number 

formats, use the options in the Format Cells dialog box. Both methods are listed below. 

 

To format numbers using the Ribbon, follow these steps: 

1) Select the cell(s) whose number format you want to change. 

2) In the Number group on the Home tab, click an option from the Number 

Format drop down list (see Figure 10). The default option is the 

General style. 

3) If necessary, use the Increase/Decrease Decimal buttons found in the 

Number group to show more precise values.  

 

To format numbers using the Format Cells dialog box, follow these steps: 

1) Select the cell(s) whose number format you want to change. 

2) Click the dialog box launcher in the Number group on the Home tab. 

Figure 9: The cell fill color option found in the Font 
group on the Home tab. 

Figure 10 : The Number 
group on the Home tab. 



Microsoft Office Excel 2007 ï Grade Book 
 

 

St. Josephôs College   7 

Technology & Information Services 

3) Choose a category from the left side (see Figure 11) and adjust any additional options from the 

right side (number of decimal places, etc.). 

4) Click the OK button when finished. 

 

 

Wrap Text 

There are times when you need to wrap text with in a cell so it appears on two or more lines. To wrap 

text within a cell, follow these steps: 

1) Select the cell (or cells) where you want to wrap text. 

2) On the Home tab, in the Alignment group, click Wrap Text (outlined in 

the red square in Figure 12). 

3) Data in the cell wraps to fit the column width. When you change the 

column width, data wrapping adjusts automatically.  

4) If all wrapped text is not visible, it may be because the row is set to a 

specific height. 

 

 

 

Viewing Formulas 

You can quickly display formulas on the worksheet, and not the formula 

result, by clicking the Show Formulas option in the Formula Auditing 

group on the Formulas tab of the Ribbon (outlined in the red square in 

Figure 13). Or, use the keyboard shortcut Ctrl+` (accent mark located 

above the Tab key and to the left of the number 1 key). 

 

 

 

 

 

 

 

 

Figure 11 : There are many more number formatting options in the Format 
Cells dialog box. 

Figure 12 : The Alignment 
group found on the Home tab. 

Figure 13 : The Show Formulas 
button in the Formula Auditing group. 
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CCuussttoommiizziinngg  PPaaggee  LLaayyoouuttss  

Excel allows for a great deal of customization in how your grade book appears both on screen and 

when printed. For example, you can adjust margins, add headers and footers to pages, hide columns 

and rows from screen view, or scale a page so it fits the printed page size. Listed below are some of the 

common page layout changes you can customize. 

 

Adding Headers and Footers 

Headers and footers can be useful tools for organizing and identifying a spreadsheet. A header is a 

section of information that is printed above the body of the spreadsheet and a footer is a section of 

information that is printed below the body of the spreadsheet. Headers and footers repeat on every 

printed page of the worksheet and each worksheet in a workbook can have different headers/footers.  

 

To add headers and footers, follow these steps: 

1) Select the worksheet tab in the lower left corner to which you want to add the header/footer. 

2) On the Insert tab, in the Text group, click Header & Footer. A header appears, divided into 

three sections, and the Design tab is visible on the Ribbon. The Excel screen view changes 

from Normal to Print Layout. 

3) One section of the header appears on the left of the top margin, one in the center, and one on 

the right. Although all three sections may not be visible, clicking in one of these areas will 

trigger that section to appear (see Figure 14). 

4) Click the section of the header where you want to add content. 

5) Type in the text you want to repeat at the top of each printed page or click one of the options 

from the Header & Footer Elements group on the Design tab (current time, file name, etc.). 

a. To change the formatting of the text, select the text that you want to format.  

b. Select the Home tab and use the formatting commands in the Font group. 

6) To stop working with your header, click outside of it. 

 

To add a footer to the spreadsheet, follow the same steps as listed above with the exception of 

a change in step 2. Before entering any text, click the Go to Footer button in the Navigation 

group on the Design tab. 

 

Figure 14 : The Header area and related Design tab on the Ribbon. 

Spring 2008 Semester 
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Figure 15 : Orientation 
options found on the Page 
Layout tab. 

Adjusting Margins, Page Orientation and Other Layout Options 

In order to fit information on a page or change the appearance of a page, you may want to customize 

the page layout. Several different aspects of the page layout may be altered to customize the way the 

printed worksheet appears including: page margins, orientation, paper size, and position of the 

spreadsheet on a printed page. Directions for adjusting each of these options are listed below. 

 

To change page margins, follow these steps: 

1) Click the Margins button on the Page Layout tab. 

2) Select one of the given choices or click the Custom Margins... option. The Page Setup dialog 

box appears, with the Margins tab selected.  

3) In the Top, Bottom, Left, or Right text boxes, type the appropriate margins or use the nudge 

buttons to select the appropriate value.  

4) Click the OK button. 

 

To change the page orientation from portrait to landscape, follow these steps: 

1) Click the Page Layout tab on the Ribbon. 

2) Click the Orientation option found in the Page Setup group. 

3) Choose Landscape (see Figure 15). 

 

To change the paper size from the default size of 8 ½" x 11", follow these steps: 

1) Click the Page Layout tab on the Ribbon. 

2) Click the Size option found in the Page Setup group. 

3) Select the desired paper size (Legal, etc.). 

 

To center the spreadsheet on a printed page, follow these steps: 

1) Click the Margins button on the Page Layout tab. 

2) Click the Custom Marginsé option. The Page Setup dialog box appears, with the Margins tab 

selected. 

3) To center within the left and right margins, in the Center on page section, select Horizontally. 

4) To center within the top and bottom margins, in the Center on page section, select Vertically. 

5) Click the OK button. 

 

 

Repeating Rows and Columns 

When you are working with a large grade book, repeating information (like row or column 

descriptions) on subsequent pages can help improve the readability of the spreadsheet. You can specify 

which cells you would like to repeat on each page as print titles. After print titles have been defined, 

row headings will appear at the left of the page and column headings will appear at the top of the page 

when printing a multi-page worksheet. To set print titles, follow these steps: 

 

1) From the Page Layout tab, in the Page Setup group, click Print Titles. The Page Setup dialog 

box appears, with the Sheet tab displayed. 

2) Under Print titles, in the "Rows to repeat at top" text box, type a row reference for the row you 

want to repeat. For example, if you want row 1 to repeat, type $1:$1 

OR  

3) To select the row, click the collapse dialog button .  

4) Select the row you want to repeat by clicking it. 
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5) Click the restore dialog button . 

6) If necessary, repeat the steps to have a column repeat on the left side of every printed page. Use 

the options in the "Columns to repeat at left" text box. 

7) Click the OK button when finished. 

8) Check the printed pages for accuracy using the Print Preview option (Microsoft Office 

ButtonĄPrintĄPrint Preview). 

 

 

Hiding and Unhiding Rows and Columns 

At times, there may be information in your grade book which you no longer need to see. At other 

times, you might be printing your grade book and want to print only columns AïD and columns HïJ, 

skipping columns E,F, and G. Rather than rearrange your worksheet for either of these examples, you 

can simply hide the information. To hide rows and/or columns, follow these steps: 

 

1) Click a cell within the row or column you want to hide. 

2) On the Home tab, in the Cells group, click Format. 

3) From the Format menu, in the Visibility section, select Hide & Unhide. 

4) Click either Hide Columns or Hide Rows depending on which you are trying to hide. The 

column and/or row is hidden. 

 

To unhide columns or rows, follow these steps: 

1) Select at least one cell from both of the columns around the hidden column(s) to be 

redisplayed. For example, if column B is hidden, select a cell from both columns A and C.  

2) On the Home tab, in the Cells group, click Format. 

3) From the Format menu, in the Visibility section, select Hide & Unhide 

4) Click either Unhide Columns or Unhide Rows depending on which you are trying to display. 

The column and/or row reappears. 

 

 

Scaling Sheets 

The scaling option allows you to adjust the size of the printed copy. The default size of the printed 

copy is 100%. You can adjust the scale to a percentage of the default size, or choose to fit the 

worksheet to a specific number of pages; both allow you to reduce or enlarge the entire worksheet. 

 

To adjust the page scaling, follow these steps: 

1) Click the Page Layout tab on the Ribbon. 

2) From the Scale to Fit group (see Figure 16), in the Scale text box, 

type the appropriate percentage or with the nudge arrows, click the 

appropriate percentage. 

- OR - 

3) From the Scale to Fit group, in the Width text box, click the drop 

down arrow to select the desired number of pages.  

 

 

  

Figure 16 : The Scale to Fit 
group on the Page Layout 
tab. 
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Figure 18 : The Print Preview tab in Excel 2007. 

PPrriinnttiinngg  WWoorrkksshheeeettss  

Excel provides many options for modifying how the worksheet will appear on a printed sheet. Many 

features that appear on the screen, such as gridlines and row and column headings, will not 

automatically print. However, you may choose to include these and other elements in the printed 

worksheet. It is always a good idea to preview the worksheet on screen in a print layout view (see 

section below) and to use the options outlined in the earlier section, "Customizing Page Layouts", to 

fine tune the worksheet before sending it to the printer.  

 

Printing a worksheet is as easy as clicking the Microsoft Office Button and choosing the Print option 

found in the Office Button menu. Or, you can use the keyboard shortcut Ctrl+P.  The Print dialog box 

that appears allows you to choose a printer, print the active sheet or the entire workbook, print a range 

of pages, print multiple copies, and adjust other printing options found in the printer Propertiesé 

button (see Figure 17). 

 

Print Preview 

Previewing a worksheet using the Print Preview option can save time, paper, and the frustration of 

waiting for a printout only to discover that it is not what you want. To preview a worksheet before 

printing, follow these steps: 

1) Click the Microsoft Office Button and then point to the 

Print option. 

2) Click Print Preview on the Print submenu. The 

worksheet displays on screen with the Print Preview tab 

visible (see Figure 18). 

3) Once you are in the Print Preview view there are a few 

unique options available from the Print Preview tab. 

Options include: Print, Page Setup, Next Page, Previous 

Page, Zoom, and Show Margins. 

4) Click the Close Print Preview option when finished to return to Normal view. 

Figure 17 : The Print dialog box in Excel 2007. 
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Displaying Gridlines, Row, and Column Headings 

The Page Setup dialog box offers additional printing options you can activate for printed worksheets. 

 

1) Click the Page Layout tab on the Ribbon. 

2) Click the dialog box launcher in the 

Page Setup group. 

3) In the Page Setup dialog box that opens, click 

the Sheet tab (see Figure 19). 

4) To print gridlines, in the Print section, select 

Gridlines. 

5) To print row and column headings (the 

columns letters A, B, C, etc. and row numbers 

1, 2, 3, etc.), in the Print section, select Row 

and column headings. 

6) Click the OK button when finished and 

preview the worksheet before printing. 

 

 

 

Printing Only a Portion of a Worksheet 

You might not always want to print the entire worksheet. You can print portions of a sheet by selecting 

the range of cells to print and choosing an option in the Print dialog box. To print only a range of cells, 

follow these steps: 

1) Select the range of cells to be printed. 

2) Click the Microsoft Office Button and then click the Print 

option. 

3) In the Print What area, choose Selection (see Figure 20). 

4) Click the OK button. The specified range of cells is printed. 

 

 

 

 

  

Figure 19 : Options found on the Sheet tab of the Page 
Setup dialog box. 

Figure 20 : Choose Selection in the Print 
What area of the Print dialog box to print a 
portion of a spreadsheet. 



Microsoft Office Excel 2007 ï Grade Book 
 

 

St. Josephôs College   13 

Technology & Information Services 

GGeettttiinngg  HHeellpp  

The Microsoft Office Help system provides concise, printable descriptions and procedures for virtually 

any Office feature. The Help system is useful for troubleshooting problems and explaining specific 

subjects, making Microsoft Office a more accessible program to work with. The topics found in the 

Help system are actually stored in an extensive help library on Microsoft's Office web site. The Help 

system in the Office 2007 programs utilizes a direct connection to this web site and allows for updated 

and new content. 

 

Each program in Microsoft Office has a separate Help window. This means that when you open the 

Help window from one program, such as Microsoft Office Excel, and then go to another program, such 

as Microsoft Office Word, and open Help, you see two separate Help windows. 

 

To open the Help system, click the HELP icon  in the upper right corner of the screen (or press the 

F1 key on the keyboard) to open the Help dialog box. There are a number of buttons available in the 

Help toolbar at the top of the Help dialog box to help you navigate through the Help system: Back, 

Forward, Home, Print, Show Table of Contents, etc. (see Figure 21).  

 

There are two ways to search for help topics. You can use the search text box at the top or you can 

browse Office Help for information on your subject using the links in the main area of the window. If 

necessary, click the button in the lower right corner of the Help system dialog box to change the 

connection status to Microsoft's web site.  

 

Figure 21 : The Excel 2007 Help system dialog box. 
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Microsoft allows its users to evaluate its help topics to better assist Office users in the future. The 

critiquing option is available in every help topic and is very easy to submit. You must be connected to 

the internet to critique a topic. 

1) Open the Help dialog box. 

2) Find the topic by either searching or browsing in the Help dialog box. 

3) After reading through the help topic, click the YES or NO button, or I DON'T KNOW, as 

appropriate. The screen refreshes to include a text box. 

4) In the text box, explain your issue and the degree of the topic's helpfulness. 

5) When you are finished, click the Submit button. Your critique is submitted to Microsoft. 

OR 

6) If you choose not to critique the article, click the Back button. 
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