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INTRODUCTION 
 
 
Macromedia Dreamweaver 4.0 is a full-featured Web-design tool used by beginning and 
professional Web designers. You can use Dreamweaver to visually design your Web page in the 
new Layout view, or you can use the robust text-editing features when you want to hand-code 
your page. Either way, you’ll find creating and managing your site easy with Dreamweaver and 
the intuitive Macromedia User Interface. 
 
COURSE OBJECTIVES 
In this course you will learn to use the fundamental features of Dreamweaver. The focus of the 
lessons is to design a Web site for a fictitious company, Compass Adventure Tours. You will 
learn how to 
 
• Add text, graphics, and links 
• Manage the site 
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SYSTEM REQUIREMENTS 
 
 
You need the following hardware and software to run Macromedia Dreamweaver 4.0: 
 
MICROSOFT WINDOWS 
 

• Windows 95, 98, 2000, ME, or Windows NT 4.0 (with Service Pack 5) or later 
• Intel Pentium processor 166 MHz or greater 
• 32 MB of RAM (64 MB or greater recommended) 
• 110 MB of available disk space 
• Color monitor with 800 x 600 resolution, 256 colors 
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LESSON 1: LEARNING THE BASICS 
 
OBJECTIVES 
 
When you finish this lesson, you will understand 
 
 • The Macromedia Dreamweaver graphical user interface 

 
and you will have learned 
 

 • How to define a new site 

 • How to name, title, and save your documents 

 • How to specify preview browsers 

 • How to specify background, text, and link colors 

 • How to put text on a page 

 • How to format text 

 
 
ORGANIZING YOUR SITE 
 
Before you begin creating your Web pages, you should have some idea what the pages are to 
contain.  Developing Web pages is similar to designing print material: you develop the concept 
first. You need to ask yourself—or your client—some basic questions. Why is the Web site 
needed? What are you trying to communicate? Who are the potential viewers of the pages? What 
do you want your visitors to take away with them? 
 
Consider also what browsers your users might have. Are they likely to have the most up-to-date 
version with all the latest plug-ins? Are they more likely to have older computers and older 
browsers? The answer to the browser question determines whether you can use Cascading Style 
Sheets or layers on your pages. 
 
You also need to develop an outline of the site. The outline is similar to a storyboard for a 
multimedia project or a movie, giving you an idea of the scope of the project and a starting point 
for setting up the file structure you need. Gather the text and graphics for the Web pages, and 
then you are ready to start using Dreamweaver to put those ideas together. 
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DREAMWEAVER BASICS 
 
When you open Dreamweaver, you’ll notice the Document window, where you design your 
page, and several panels for adding or changing text and objects on the page. The Objects panel 
is used for adding objects such as images, tables, layers, or Flash animations to the page. The 
Property inspector lets you change the attributes of selected text or of an object on the page. All 
of the panels and the Property inspector can be accessed from the Window menu. 
 
A check mark next to an item in the Window menu indicates that the panel is open, but it could 
be hidden beneath another panel or the Document window. To display a hidden panel, select it 
again from the Window menu. 
 
If a panel is selected but still doesn’t appear, choose Window > Arrange Panels to reset all 
open panels to their default positions. The Objects panel moves to the upper left of the screen, 
the Property inspector moves to the bottom of the screen, and all other open panels move to the 
right of the screen, with no overlap. 
 
 
THE DOCUMENT WINDOW 
 
The Document window is where you will do most of your work (see Figure 1-1). It gives you an 
approximate representation of your page as you add and delete elements. The title bar shows the 
document’s title and file name. The toolbar lets you select the document view and enter the 
document title.  
 

Document title bar 

 

 
Figure 1-1 
The Document window. 
Toolbar
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THE OBJECTS PANEL 
 
The Objects panel contains the objects or elements you want to add to your page (see Figure 1-
2). Among them are images, tables, special characters, forms, and frames. To insert an object, 
drag the object’s icon from the Objects panel to its place in the Document window. Another 
method is to place the insertion point in your document where the object should appear and then 
click the object’s icon on the panel. The object is inserted into the document at the insertion 
point. 
 
You can select from several panels within the Objects panel. They can be accessed from the 
Options pop-up menu at the top of the Objects panel. For example, the objects you need to create 
a form are on the Form Objects panel. 
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THE PROPERTY INSPECTOR 
 
On the Property inspector, you can view and change the attributes of an object (see Figure 1-3). 
The inspector is context sensitive — it changes based on what you have selected in the 
Document window. Depending on the selected object, there might be additional properties that 
are not visible. To see all the properties, click the expander arrow located in the lower-right 
corner of the inspector. 
 

 Figure 1-3 
The Property inspector 

 
 
 
DOCKABLE PANELS 
 
Many of the panels can be docked together; that is, you can combine them into tabbed windows. 
This maximizes your screen area while giving you quick access to the panels you need. To dock 
a panel, click its tab and then drag it over another panel or set of docked panels. When the border 
of the second panel highlights, drop the panel. To select a panel from a set of docked panels, 
click its tab. To undock panels, drag the tab out of the window. 
 
You’ll also notice that the Document window and the panels snap to each other or to the sides of 
your screen. This helps you better manage your workspace. 
 
You can minimize all your open documents and panels by choosing Window > Minimize All. If 
you have at least one open window, you can restore all the minimized windows by choosing 
Window > Restore All. 
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DEFINING A LOCAL SITE 
 
Before you begin to create individual Web pages, you need to create the site that contains those 
pages. This local site on your hard drive will mirror the actual pages on the Web server. The 
local site is where you do all of your initial development and testing. To set up a local site, create 
a folder on your hard drive. The name of the folder can be the name of the site or any name you 
choose. For example, in class you have a folder called DW4_WebDesign that contains all the 
files and folders you are using in class. 
 
Note:Your local folder should not be saved within the Dreamweaver application folder. If you 
ever need to reinstall Dreamweaver, your work would be lost.  
 
After you define the main folder, it becomes the root folder for your site. All your files and 
subfolders are contained within that root folder. Dreamweaver needs a properly defined site with 
a unique local root folder to maintain and update links between pages. When you upload a site, 
the relative links that worked within the local root will also work on the server. When you are 
ready to publish your site, all you have to do is copy that folder and all of its files to the remote 
server. The images and links should all work (assuming that they work locally). 
 
If you connect a local site to a remote site, Dreamweaver maintains identical directory structures 
to ensure that links and references are not accidentally broken. If directories do not exist in the 
site where you are transferring files, Dreamweaver automatically creates them. 
 
You must first save a document within a local site before document-relative links will work. In 
all dialog boxes where you link a file to the current document, you should choose to define the 
path document-relative. 
 
Document-relative paths are the best choice to use for local links in most Web sites. Document-
relative paths define the path to take to find the linked file, starting from the document. For 
example, a path to a file in the same folder would be expressed as myfile.htm. To link to a file in 
a subfolder of the current document, the path would be expressed as content/myfile.htm. To link 
to a file in the parent folder of the current file, the path would be expressed as ../myfile.htm. 
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To create a new local site: 
 

1. Choose Site > Define Sites. 
 

The Define Sites dialog box opens, as shown in Figure 1-4. This dialog box lists all the 
sites you have previously defined and lets you create new ones. 

 Figure 1-4 
The Define Sites dialog box 
 

2. Click New to create a new site. 
 
  The Site Definition dialog box opens, as shown in Figure 1-5. 

  
Figure 1-5 
The Site Definition dialog box. 
 

3. The name you assign to the site can be anything that identifies the site—this is for your 
reference only.  For this class, type your name in the Site Name text box. 
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4. Click the folder icon next to the Local Root Folder text box. 

The Local Root Folder text box specifies the folder on your hard drive where the files for this 
site are stored. It is the local equivalent of the site root folder at the remote site. Dream 
weaver creates all siteroot-relative links relative to the local root folder. 

5. Locate the DW4_WebDesign folder on the desktop. 

• Select the DW4_WebDesign folder and click Open . Then click Select to use the 
DW4_WebDesign folder as your root folder. 

6. In the Site Definition dialog box, select Refresh Local File List Automatically. 

When this option is selected, Dreamweaver updates the site list whenever you add a new file 
to the site folder. If you don’t check this option, you’ll need to refresh the local files 
manually. 

7. Select Enable Cache and then click OK. 

When this option is selected, a local cache is created, improving the speed of linking and 
site-management tasks. You will usually want to select this option; however, at very large 
sites, re-creating the cache can slow operations. 

8. If “The initial site cache will be created” message box appears, click OK and then click 
Done. 
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SPECIFYING PREVIEW BROWSERS 
 
As you develop your Web pages, you will want to view your efforts in a browser—or in fact, in 
several browsers.  In Preferences, you can specify which browsers you would like to use to 
preview your pages.  To simplify the preview process, Dreamweaver has keyboard shortcuts for 
viewing your pages in two different browsers, called the primary and secondary browsers. 
 
To select preview browsers: 
 

1. Do the following: 

• Choose Edit > Preferences and select Preview in Browser from the Category list on 
the left. 

 
The Preferences dialog box opens, as shown in Figure 1-6. Clicking a browser name in the 
window on the right shows you whether it’s the primary or secondary browser, or neither. 

Figure 1-6 
The Preferences dialog box for Preview in Browser. 

 
2. Do the following to select the browsers you want to use in previewing your pages: 

• Click the plus (+) button to add a browser to the list. When the dialog box opens, find 
the browser application. Select Primary Browser if you want to launch this browser by 
pressing F12 when previewing your pages. Select Secondary Browser to preview your 
document by pressing Control+F12. You’ll be using these shortcuts often, so memorize 
them quickly. 
• To remove a browser from the list, select the browser name in the list and then click the 
minus (–) button. 
• To change a browser choice, select the browser name in the list. Then click Edit and 
locate a different browser. 

 3.  Click OK when you are done adding or changing browsers. 
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SAVING YOUR FILE 
 
You should save your documents in Dreamweaver as soon as you open a new document. Don’t 
wait until you have text or graphics on the page. This way, when you do import graphics or other 
media, all references will be created properly. 
 
NAMING AN HTML FILE 
 
Naming your files for use on a Web server is a little different from naming your files for your 
hard drive.  Your best bet is to use lowercase names for your files and keep the file names short. 
That way, your file names work on all servers. Here are some other rules to follow: 
 

• Don’t use spaces within your file names. Use the underscore or dash character to 
simulate a space to separate words. 

 • Use letters and numbers, but no special characters, such as %, *, or /. 
 • Avoid beginning your file names with a number. 
 • Make sure you don’t leave a space at the end of the file name. 

• The same goes for folder names—don’t use spaces. If you do, you’ll notice that 
browsers substitute %20 for the spaces. 

 
Note: 
Keep your folder names short. Remember that the folder name becomes part of the URL you 
type to get to the page. 
 
 
To save your document: 
 

1. Choose File > Save As and select the folder you created to hold your web pages.  For our 
example, we will choose the DW4_WebDesign folder located on the Desktop. 

Figure 1-7 
The Save As dialog box. 

 
2. If you are creating a web site, the home page of the site should always be called 

index.html.  If you are just creating an html document and it will not be used on a web 
site, you may use any document name that you would like. 

 
  For the filename, enter index.html. 
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GIVING YOUR PAGE A TITLE 
 
Every HTML document should have a title. The title, used primarily for document identification, 
is displayed in a browser’s title bar and as the bookmark name. Choose a short phrase that 
describes the document’s purpose.  The title can be of any length: you can crop it if it’s too long 
to fit in the browser’s title bar. 
 
Get in the habit of adding the title to each page you create before you add text or graphics to the 
page. If you forget, Dreamweaver defaults to “Untitled Document”—you don’t want to keep that 
for the page name. 
 
To add the page title: 
 

1. If you don’t see the Title text box at the top of the Document window (below the menu 
bar), choose View > Toolbar. 

2. Type Surfer’s Paradise in the Title text box and then press Enter (Windows) or click in 
the document. 

 
 
 
 
 
 
 

Figure 1-8 
The Title box. 

 
Note: Dreamweaver gives you several reminders if you haven’t titled your page. Look at the 
document title bar. It contains the title and the file name. If you see “Untitled Document 
(filename.htm),” you haven’t titled your document. You’ll also see “Untitled Document” in the 
title area of the Document window. 
 
 
PLACING TEXT ON A PAGE 
 
You can add text to a page by typing it or by copying and pasting from an existing text 
document.  
 
Type in the following text: 
 
Aloha! Welcome to Surfer's Paradise, where you'll be treated like one of the family. Hawaii has 
the most spectacular surfing on the planet Earth, and we'd like to share it with you.  
 
We have all different levels of surfing, from newbie locations to places that will wow even the 
most jaded surfer. Take a look at our finest offerings for the well-waxed. 
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COPYING TEXT FROM EXISTING DOCUMENTS 
 
If you have text that already exists in another document, you can copy and paste that text into the 
html document that you are creating. 
 
For example, a word document called surf_hawaii has all of the text that you need for the web 
page you are creating.  You would open this word document, copy the text and then paste it into 
the document you are creating. 
 
To copy text:
 

1. Minimize the Dreamweaver window by clicking once on the gray box with the single 
black dash located in the upper right corner of the screen. 

 
 
 
 
 

Figure 1-9 
The Minimize button in the upper right corner. 

 

Click here 

2. Start the Microsoft Word application and choose File > Open.  Select the surf_hawaii 
word document located in the DW4_WebDesign folder located on the Desktop. 

Figure 1-10 
The File Open dialog box. 

3. Select the text that you want to copy by positioning the mouse at the beginning of the third 
paragraph and then clicking with the left mouse button and dragging all the way down to 
the bottom of the document. 

4. Choose Edit > Copy. 
5. Minimize the Microsoft Word application by clicking once on the gray box with the single 

black dash located in the upper right corner of the screen. 
6. Maximize the Dreamweaver window by clicking once on the Dreamweaver button located 

on the Start bar on the bottom of your screen. 

 
7. Choose Edit > Paste. 
8. Choose File > Save. 
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SPECIFYING A BACKGROUND COLOR 
 
In Dreamweaver you can easily change the background color of a page by using a preset palette 
of colors known as the Web-safe color palette . You access that palette in the Page Properties 
dialog box. For more colors, click the arrow located in the upper-right corner of the color pop-up 
window and select a color palette from the pop-up menu. 
 
To select a background color: 
 

1. Choose Modify > Page Properties. 

  The Page Properties dialog box opens. 
2. Click the Background color box. A color palette opens. 
3. Move the eyedropper over a color swatch. 

The swatch’s hexadecimal equivalent is shown at the top of the color palette, as shown in 
Figure 1-11. 

 4.  Click a pale blue color to select it. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click here 
for colors. 

Figure 1-11 
The Page Properties dialog box  

 5.  Click Apply to view the color change to your document. 
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SPECIFYING THE DEFAULT FONT COLOR 
 
When you change the background color, you may also need to change the color of the text that is 
displayed. Obviously, black text won’t be visible on a black background. 
 
To change the default font color:
 

1. In the Page Properties dialog box, click the Text color box. 

A color palette opens. 
2. Select a color for your text—dark blue would look good—and click OK to close the Page 

Properties dialog box and return to your document. 
 
 
APPLYING A HEADING FORMAT 
 
Applying a heading format to text changes its appearance to larger and bolder fonts.  
 
To apply a heading format: 
 
 1. Insert a new line at the top of the page. 
 2. Type Hawaii - Surfer’s Paradise in that new line. 
 3. From the Property inspector’s Format pop-up menu, select Heading 3 (see Figure 1-12). 

 
You have now tagged the text as a level 3 heading. 

 
 
 
 
 
 
Figure 1-12 
The Property inspector’s Format menu. 

 
HTML has six levels of headings—numbered 1 through 6—with heading 1 having the largest 
font size. Headings are displayed in larger or bolder fonts than the normal body text. Tagging a 
paragraph as a heading automatically generates a space below the heading. You cannot control 
this spacing. 
 
Note: In many documents, the first heading is identical to the title. For multipart documents, the 
text of the first heading should be related information (such as a chapter title), and the title tag 
should identify the document in a wider context (it could include both the book title and the 
chapter title). 
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INDENTING TEXT 
 
Often you’ll want to indent the text on the page. You can use the Text Indent and Text Outdent 
icons in the Property inspector to do this, as shown in Figure 1-13. Using Text Indent indents 
text at the left and right margins of the page. You cannot control the amount of indentation. 
 
 
 
 
 
 

Figure 1-13 
The Text Indent and Text Outdent icons. 
 

Text Outdent   Text Indent 

To indent paragraphs:
 
 1. Select the first six body paragraphs of your surf_hawaii.htm document. 
 2. Click Text Indent in the Property inspector or choose Text > Indent. 
 
To remove indentation:
 
 1. Select the first two body paragraphs of the document. 
 2. Click Text Outdent in the Property inspector or choose Text > Outdent. 
 3. Save the file and preview it in the browser. 
 
 
MAKING LISTS 
 
Dreamweaver gives you three kinds of lists: ordered (numbered), unordered (bulleted), and 
definition lists (a term and its definition). 
 
ORDERED LISTS 
 
An ordered list consists of list items that are ordered numerically or alphabetically. You have the 
option of using arabic or roman numerals or using uppercase or lowercase letters. 
 
To create an ordered (numbered) list:
 
 1. Select the four lines of text “Sunset Beach, Oahu,” “Waimea Bay,” “South Shore, Oahu,” 
  and “Pipeline.” 

2. Click Ordered List in the Property inspector (shown in Figure 1-14) or choose Text > List 
> Ordered List. 

 



 

  
LESSON 1      15                      MACROMEDIA DREAMWEAVER 4 

  

The selected text is indented and numbered. 
 
 
 
 
 
 

Figure 1-14 
The Ordered and Unordered List icons. 

 

Unordered List   Ordered List

You can change the numbering scheme of ordered lists by modifying the list’s properties. 
 
To change ordered list properties: 
 

1. Click the line with the text “Sunset Beach” or any line in the list. 

Select only one line from the list. If you select multiple lines, the List Item button is 
dimmed and not available for you to use. If the List Item button is not visible, click the 
expander arrow in the lower-right corner of the Property inspector. 

 2. Click List Item in the Property inspector or choose Text > List > Properties. 

The List Properties dialog box opens (see Figure 1-15). 

 
Figure 1-15 
The List Properties dialog box. 

 
3. From the Style pop-up menu, select Alphabet Small (a, b, c) and then click OK. 

All items in the list are alphabetized. 
4. Save the file and preview it in the browser. 
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UNORDERED LISTS 
 
Unordered lists are often called bulleted lists because each list item has a bullet in front of it. The 
bullet symbol Dreamweaver displays by default can be changed to a disc, a circle, or a square. 
 
To create an unordered (bulleted) list: 
 

1. Select the text starting with “East to southeast winds” and ending with “Water temperature 
at 76 degrees Fahrenheit.” 

2. Click Unordered List in the Property inspector or choose Text > List > Unordered List. 

The selected text is indented and bulleted. 
 
You can change the default bullet symbol of unordered lists by modifying the list’s properties. 
 
To change unordered list properties:
 
 1. Click any line in the list. 

2. Click List Item in the Property inspector or choose Text > List > Properties. 

  The List Properties dialog box opens (see Figure 1-16). 
 

If the List Item button is dimmed, you have more than one item selected. If the List Item 
button is not visible, click the expander arrow in the lower-right corner of the Property 
inspector. 

Figure 1-16 
The List Properties dialog box 

 3. From the Style pop-up menu, select Square and click OK. 

  All items in the list now use the square bullet symbol. 
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DEFINITION LISTS 
 
A definition list consists of a series of terms and their definitions. The word or term to be defined 
is left-justified; the definition is indented and placed on the next line. For this formatting to work, 
a term and its definition must each be a separate paragraph. 
 
To create a definition list:
 

1. Select the text starting with “Crest” and ending with “The time for a wave crest to travel 
one wave length.” 

2. Choose Text > List > Definition List. 
The terms are now at the left margin, and their indented definitions are on succeeding 
lines. 

3. Save the file and preview it in the browser. 
 
 
LIST TIPS 
 
When you’re creating lists, keep these tips in mind: 
 

• To change a bulleted list to a numbered list or a numbered list to a bulleted list, select the 
entire list and then apply the other list format. 
• To convert a list to plain text, select the list and apply the list type again. This procedure 
works like a toggle to turn off the list formatting. 
• If you had extra text selected when you applied the formatting for the list, select the extra 
text and apply the formatting again to remove the list formatting. 

 • If you are typing within an already formatted list and you want to end the list, press Enter 
 twice. 

• List items are single-spaced by default. If you want extra spacing between the lines, 
select all the items in the list and then choose Paragraph from the Format pop-up list of the 

 Property inspector. 
 
 
CHARACTER FORMATTING 
 
Occasionally you will need a word or phrase to look different from the surrounding text. For 
example, you might want a word to be bold or italicized to visually set it apart from other text. 
 
To make text bold: 
 
 1. Select the word “Crest” in the definition list you just created. 
 2. Click Bold (the dark capital “B”) in the Property inspector or choose Text > Style > Bold. 
 

The selected text now has bold formatting applied to it. 
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Many times you will find yourself repeating the most recent formatting you applied on another 
paragraph or other selected text. The Repeat command makes that task easier, with a simple 
keystroke. The first two items listed on the Edit menu are the Undo and Repeat commands. 
You’ll want to remember their keyboard shortcuts: 
 
 • Undo: Control+Z  
 • Repeat: Control+Y 
 
To repeat a command:
 
 1. Select the word “Trough” in the definition list. 
 2. Press Control+Y  
  Because you used the Bold command most recently, it is applied to the selected text. 

3. Repeat the bold formatting on the other terms in the definition list. 
4. Also apply bold to the text "Dead Man's Bluff", "Long Cool One", "Piece of Cake", and 

"Gripper".  
 
POSITIONING TEXT 
 
If you want to force a line break in the text, you need to insert a line break character. This would 
be useful for an address line, for example, where you want a new line for each line in the address 
without the extra spacing of a paragraph. You also may want to center some text, such as a 
heading, to make it more prominent. 
 
To create a line break: 
 

1. In the paragraph that begins with “Besides helping you find”, position the insertion point 
before the text “Big Kahuna Surf and Swim Shop.” 

 2.  Press Shift+Enter. 
The text after the insertion point moves to the next line. A new paragraph has not been 
created, so there is no additional spacing between the two lines. 

3. Repeat steps 1 and 2 to move the text “1134 Paradise Lane” to the next line and “Hawaii, 
USA” to a new line. 

4. Position the insertion point before the text “Sign up at” and then press Enter to insert a 
new paragraph. 

5. Save the file and preview it in the browser. 
 
To center text on a page:
 
 1. Position the insertion point in the heading “Hawaii - Surfer's Paradise.” 
 2. Click Align Center in the Property inspector (see Figure 1-17). 

The heading is now centered. 
 
 
 

Figure 1-17 

Align Center

The Align Center icon  



 

  
LESSON 1      19                      MACROMEDIA DREAMWEAVER 4 

  

CHANGING FONT PROPERTIES 
 
To make your page more interesting and easier to read, you may want to change the typeface 
used to display the text. Although a great deal of information is a vailable concerning how type is 
used for print, not all of that knowledge translates to the Web. You have to consider the fact that 
users are free to change the screen size or to change the font size and color of the text. The way 
type flows on a page can easily change from user to user. There is also a dramatic difference 
between font sizes in Windows and on a Macintosh. Macintosh computers display text 
approximately 75 percent smaller than the size of the same text in Windows. 
 
If you are accustomed to print work, you may be frustrated by the lack of typographic control, 
such as line and letter spacing, in HTML. You also can’t control widows (a single word on a 
line) in Web text, and you can’t control line breaks in paragraphs. You should remember that text 
support on the Web is still very primitive. You need to work within the constraints of the 
medium. 
 
CHANGING THE FONT FACE 
 
You can change the font for the entire page or for selected text on the page. However, for users 
to see your page as you designed it, the font you choose must be installed on the user’s computer. 
Do not make the assumption that all fonts are loaded on everyone’s computer. If your first choice 
is not available, the browser will attempt to use the second choice and then the third. If none of 
the fonts are a vailable on the user’s computer, the text will be displayed in the browser’s default 
font. In the following exercises, you will make some simple font changes to the text on the page. 
 
To change the font face of a single paragraph:
 
 1. Select the text “Hawaii - Surfer’s Paradise.” 

2. From the Property inspector’s Font pop-up menu, choose Arial, Helvetica, Sans-serif (see 
Figure 1-18). 
The selected text changes to another font, depending on the fonts installed on your  
computer. 

 
 
 
 
 
 
 
 

Figure 1-18 
The Property inspector’s Font menu. 
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To change the font face of multiple paragraphs:
 
 1. Select the remainder of the text on the page. 
 2. From the Property inspector’s Font pop-up menu, choose Arial, Helvetica, Sans-serif. 
  All the text now has the same font face. 

3. Save the file and preview it in the browser. 
 
To remove font face settings: 
 

1. Select the text whose font you want to remove. 
2. Choose Default Font from the Font pop-up menu in the Property inspector or choose 

Text > Font > Default Font. 
 
 
CHANGING THE FONT SIZE 
 
In HTML, the options for changing the font size on the page are limited. 
 
To change the font size: 
 
 1. Select the text "Hawaii-Surfer's Paradise." 

2. Select the size from the Property inspector’s Size pop-up menu (see Figure 1-19). You can 
also choose Text > Size or Text > Size Change to pick the size from the pop-up 
submenus. 
 
Note that the sizes are listed as 1 through 7, +1 through +7, and –1 through –7. Selecting 
just the number (1 is smallest, 7 is largest) sets the absolute size. Picking a plus or minus 
number chooses the font size relative to the base size of the font. For example, +1 makes 
the font size one size larger than the base size. 

 
 
 
 
 
 
 
 
 

Figure 1-19 
The Property inspector’s Size menu. 

 
Note: The default base size for text in your browser is set to 3. If you choose +3 for the font size, 
you are effectively changing the size to 6 (3 + 3). The largest size for a font is 7 and the smallest 
is 1. Any font size larger than 7 will be displayed as 7. For example, if you set the font size to +6, 
3 + 6 is larger than 7, so the font and will be displayed as 7. 
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CHANGING THE FONT COLOR 
 
You can easily change the color of your text in Dreamweaver.  
 
To change the font color: 
 
 1. Select the text “Hawaii - Surfer’s Paradise.” 
 2. Select a color from the Property inspector’s Text color pop-up menu (see Figure 1-20).  

3. Save the file and preview it in the browser. 
 
 
 
 
 
 
 
 
 

Figure 1-20 
The Property inspector's text color menu. 

 
 
ADDING HORIZONTAL RULES 
 
A horizontal rule is a line that goes across the page and provides a visual division between 
sections of your page. 
 
To add a horizontal rule: 
 

1. On the Common Objects panel, drag a horizontal rule to the very bottom of the document 
or choose Insert > Horizontal Rule. 

2. In the Property inspector, type 90 in the W (width) text box (see Figure 1-21). 
3. Select % from the pop-up menu to the right of the text you just typed. 

The horizontal rule extends across 90 percent of the browser window regardless of the 
browser width. It is displayed as a shaded bar centered across the page. 

Figure 1-21 
The Property inspector for a horizontal rule. 

Note: Select pixels from the menu to specify an absolute width. If you choose this option, the 
rule is not resized when users resize the browser window. 
 4. Deselect Shading to display a solid bar. 
 5. Type 3 in the H (height) text box. 

The horizontal rule is 3 pixels in height. 
 6. From the Align pop-up menu, select Left. 

The thick, unshaded bar moves to the left but still extends across 90 percent of the browser 
window. 

 7. Save the file and preview it in the browser. 
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ADDING SPECIAL CHARACTERS TO YOUR PAGE 
 
When working in Dreamweaver, you are generally typing at the keyboard. Sometimes you need 
characters and other information that is not directly accessible from the keyboard. With 
Dreamweaver, you can easily insert special characters, e-mail links, and dates. 
 
To enter special characters: 
 

1. On the Character Objects panel, drag the copyright character (shown in Figure 1-22) to the 
bottom of the page. (If you don’t see the Characters panel, click the arrow at the top of the 
Objects panel and choose Characters from the pop-up menu.) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-22 
Choosing the copyright character. 

 

Copyright 

 2. To the right of the copyright symbol, type 2000, Compass Adventure Travel. 
 3. Save the file and preview it in the browser. 
 
 
ADDING E-MAIL LINKS 
 
Linking to an e-mail address makes it easy for your visitors to contact you from a Web page. 
You should always include some method to allow visitors to correspond or interact with 
someone in your organization. 
 
To enter an e-mail link: 
 
 1. Place the insertion point on the line following the copyright you created earlier. 
 2. Click E-Mail Link on the Common Objects panel or choose Insert > E-Mail Link. 
 The Insert Email Link dialog box opens, as shown in Figure 1-23. 
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Figure 1-23 
The Email Link dialog box. 
 

3. Make the following changes and then click OK. 
 

• For Text, type Send us your questions! 
• For E-Mail, type your e-mail address. 
 
The text appears as a link. The Property inspector shows the e-mail address in the Link 
text box. 

4. Save the file and preview it in the browser. 
 
To manually type an e-mail link: 
 
 1. Select the text you want to make an e-mail link. 

2. In the Link text box of the Property inspector, type mailto: followed by the e-mail 
address. Make sure you type the colon and no spaces. 

 
 
ADDING A DATE AUTOMATICALLY 
 
Sometimes you will need to keep track of the date when you last modified a page in your site. 
Dreamweaver lets you place the date and time on your pages to track this information. The date 
and time can be updated automatically so you don’t have to do it. 
 
To insert the date: 
 
 1. Place the insertion point on the line following the e-mail link. 

2. Click Date on the Common Objects panel or choose Insert > Date to place the current date 
on the page. 
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The Insert Date dialog box opens (see Figure 1-24). 

Figure 1-24 
The Insert Date dialog box. 

 3. Make the following changes and then click OK: 
• Select Thursday, from the Day Format pop-up menu. 
• Select March 7, 1974 from the Date Format pop-up menu. 
• Select 10:18 PM from the Time Format pop-up menu. 
• Select Update Automatically on Save to update the date on your page each time you  

save your document. 
 
The current day, date, and time are displayed. This information will change every time you 
save your document. 
 

To change the date format if it is automatically updated: 
 
 1. Click the date in your document. 

2. In the Property inspector, click Edit Date Format. 

The Edit Date Format dialog box opens. This dialog box is the same as the Insert Date 
dialog box shown in Figure 1-24. 

 3. Make appropriate changes to the options and then click OK. 
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LESSON 2: SENDING YOUR PAGES TO ST. JOSEPH'S WEB SERVER 
 
OBJECTIVES 
 
When you finish this lesson, you will have learned 
 
 • How to set up a connection to a remote site 
 • How to copy files to and from a remote site 
 
 
CONNECTING TO A REMOTE SITE 
 
In Lesson 1, you created a local site—that is, a folder on your hard drive to store all the folders 
and files needed for your site. You’ve been working in the local site, developing pages and 
testing links. For visitors to see your Web pages, however, you need to copy them to a remote 
site. Typically, the remote site is on a server specified by your Web administrator or client, but it 
could also be on a local network. 
 
After creating your local site, you choose which remote site to connect to and the attributes of 
that remote site.  
 
To set up a connection to a remote site: 
 
 1. Choose Site > Define Sites. 
 The Define Sites dialog box opens, as shown in Figure 2-1. 

Figure 2-1 
The Define Sites window. 

 
2. Select your site from the list and click Edit. 
 The Site Definition dialog box opens (see Figure 2-2). 
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          Figure 2-2 
FTP settings in Site Definition dialog box. 

 
 3. In the Category list on the left, select Remote Info. 

4. From the Access pop-up menu, select FTP. 
5. In the FTP Host box, enter faculty.sjcny.edu. 
6. In the Login box, enter your username.  (This name is provided to you when you have an 

account set up on the web server.) 
7. Enter your password. 
8. Click OK to save your site information. 
9. Click Done to close the Define Sites dialog box. 

 
The Site window displays the file and folder structure of your site. You use this window to copy 
your pages to the web server.    
 
To access the Site window and connect to the remote host: 
 

1. Choose Site > Open Site and select your site from the list. 
 The Site window opens, showing only your local files (see Figure 2-3). 

Figure 2-3 
The Site window. 
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The default settings place your local files in the right pane of the Site window. When you 
connect to the remote site, the remote files appear in the left pane. 
 

2. Choose Site > Connect. 
You will be connected to the web server.  The remote host is shown in the left pane of the 
site window. (see Figure 2-4) 

       Figure 2-4 
 

3. Click once on the root folder located in the local folder pane (right pane). 
4. Choose Site > Put. 

Your entire site will be copied onto the web server. (see Figure 2-5) 

         Figure 2-4 
 

5. Choose Site > Disconnect to disconnect from the remote site. 
6. To view your web site, start your web browser and type in the following url: 

faculty.sjcny.edu/~lastname   (replace lastname with your lastname) 
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