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INTRODUCTION 
 
 
Macromedia Dreamweaver 4.0 is a full-featured Web-design tool used by beginning and 
professional Web designers. You can use Dreamweaver to visually design your Web page in the 
new Layout view, or you can use the robust text-editing features when you want to hand-code your 
page. Either way, you’ll find creating and managing your site easy with Dreamweaver and the 
intuitive Macromedia User Interface. 
 
COURSE OBJECTIVES 
In this course you will learn to use the fundamental features of Dreamweaver. The focus of the 
lessons is to design a Web site for a fictitious company, Compass Adventure Tours. You will learn 
how to 
 
• Add graphics and links 
• Create more than one page 
  Manage the site 
  
 
SYSTEM REQUIREMENTS 
 
 
You need the following hardware and software to run Macromedia Dreamweaver 4.0: 
 
MICROSOFT WINDOWS 
 

• Windows 95, 98, 2000, ME, or Windows NT 4.0 (with Service Pack 5) or later 
• Intel Pentium processor 166 MHz or greater 
• 32 MB of RAM (64 MB or greater recommended) 
• 110 MB of available disk space 
• Color monitor with 800 x 600 resolution, 256 colors 
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ORGANIZING YOUR SITE 
 
Before you begin creating your Web pages, you should have some idea what the pages are to 
contain.  Developing Web pages is similar to designing print material: you develop the concept 
first. You need to ask yourself—or your client—some basic questions. Why is the Web site 
needed? What are you trying to communicate? Who are the potential viewers of the pages? What 
do you want your visitors to take away with them? 
 
Consider also what browsers your users might have. Are they likely to have the most up-to-date 
version with all the latest plug-ins? Are they more likely to have older computers and older 
browsers? The answer to the browser question determines whether you can use Cascading Style 
Sheets or layers on your pages. 
 
You also need to develop an outline of the site. The outline is similar to a storyboard for a 
multimedia project or a movie, giving you an idea of the scope of the project and a starting point 
for setting up the file structure you need. Gather the text and graphics for the Web pages, and then 
you are ready to start using Dreamweaver to put those ideas together. 
 
 
DREAMWEAVER BASICS 
 
When you open Dreamweaver, you’ll notice the Document window, where you design your page, 
and several panels for adding or changing text and objects on the page. The Objects panel is used 
for adding objects such as images, tables, layers, or Flash animations to the page. The Property 
inspector lets you change the attributes of selected text or of an object on the page. All of the 
panels and the Property inspector can be accessed from the Window menu. 
 
A check mark next to an item in the Window menu indicates that the panel is open, but it could be 
hidden beneath another panel or the Document window. To display a hidden panel, select it again 
from the Window menu. 
 
If a panel is selected but still doesn’t appear, choose Window > Arrange Panels to reset all open 
panels to their default positions. The Objects panel moves to the upper left of the screen, the 
Property inspector moves to the bottom of the screen, and all other open panels move to the right 
of the screen, with no overlap. 
 



 

   
 

THE OBJECTS PANEL 
 
The Objects panel contains the objects or elements you want to add to your page (see Figure 1-2). 
Among them are images, tables, special characters, forms, and frames. To insert an object, drag the 
object’s icon from the Objects panel to its place in the Document window. Another method is to 
place the insertion point in your document where the object should appear and then click the 
object’s icon on the panel. The object is inserted into the document at the insertion point. 
 
You can select from several panels within the Objects panel. They can be accessed from the 
Options pop-up menu at the top of the Objects panel. For example, the objects you need to create a 
form are on the Form Objects panel. 
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THE PROPERTY INSPECTOR 
 
On the Property inspector, you can view and change the attributes of an object (see Figure 1-3). 
The inspector is context sensitive — it changes based on what you have selected in the Document 
window. Depending on the selected object, there might be additional properties that are not visible. 
To see all the properties, click the expander arrow located in the lower-right corner of the 
inspector. 
 

 Figure 1-3 
The Property inspector 

 
 
DEFINING A LOCAL SITE 
 
Before you begin to create individual Web pages, you need to create the site that contains those 
pages. This local site on your hard drive will mirror the actual pages on the Web server. The local 
site is where you do all of your initial development and testing. To set up a local site, create a 
folder on your hard drive. The name of the folder can be the name of the site or any name you 
choose. For example, in class you have a folder called DW4_WebDesign that contains all the files 
and folders you are using in class. 
 
Note:Your local folder should not be saved within the Dreamweaver application folder. If you ever 
need to reinstall Dreamweaver, your work would be lost.  
 
After you define the main folder, it becomes the root folder for your site. All your files and 
subfolders are contained within that root folder. Dreamweaver needs a properly defined site with a 
unique local root folder to maintain and update links between pages. When you upload a site, the 
relative links that worked within the local root will also work on the server. When you are ready to 
publish your site, all you have to do is copy that folder and all of its files to the remote server. The 
images and links should all work (assuming that they work locally). 
 
If you connect a local site to a remote site, Dreamweaver maintains identical directory structures to 
ensure that links and references are not accidentally broken. If directories do not exist in the site 
where you are transferring files, Dreamweaver automatically creates them. 
 
You must first save a document within a local site before document-relative links will work. In all 
dialog boxes where you link a file to the current document, you should choose to define the path 
document-relative. 
 
Document-relative paths are the best choice to use for local links in most Web sites. Document-
relative paths define the path to take to find the linked file, starting from the document. For 
example, a path to a file in the same folder would be expressed as myfile.htm. To link to a file in a 
subfolder of the current document, the path would be expressed as content/myfile.htm. To link to a 
file in the parent folder of the current file, the path would be expressed as ../myfile.htm. 
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To create a new local site: 
 

1. Choose Site > Define Sites. 
 

The Define Sites dialog box opens, as shown in Figure 1-4. This dialog box lists all the sites 
you have previously defined and lets you create new ones. 

 Figure 1-4 
The Define Sites dialog box 
 

2. Click New to create a new site. 
 
  The Site Definition dialog box opens, as shown in Figure 1-5. 

  
Figure 1-5 
The Site Definition dialog box. 
 

3. The name you assign to the site can be anything that identifies the site—this is for your 
reference only.  For this class, type your name in the Site Name text box. 
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4. Click the folder icon next to the Local Root Folder text box. 

The Local Root Folder text box specifies the folder on your hard drive where the files for this 
site are stored. It is the local equivalent of the site root folder at the remote site. Dreamweaver 
creates all site root-relative links relative to the local root folder. 

 
5. Select the Down arrow in the Look In Box and Select Desk Top. 
6. Select the Create a New Folder Icon and call the name of the new folder DW4_WebDesign. 

 

Create New 
Folder Icon 

 

7. Once the folder is created, Select the DW4_WebDesign folder and c
8. Then click Select to use the DW4_WebDesign folder as your root fol
9. In the Site Definition dialog box, select Refresh Local File List Aut

When this option is selected, Dreamweaver updates the site list when
the site folder. If you don’t check this option, you’ll need to refresh th

10. Select Enable Cache and then click OK. 

When this option is selected, a local cache is created, improving the s
site-management tasks. You will usually want to select this option; ho
re-creating the cache can slow operations. 

11. If “The initial site cache will be created” message box appears, click 
 
To Open An Existing Site:
 
Choose Site > Site Map 
Select Site again > Open Sites 
 The Site Map will open with your folders and files in it. 
 
Select the file you want to edit or create a new file in your site. 
 

Figure 2.1
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WORKING WITH GRAPHICS 
 
All current browsers support both GIF and JPEG graphic formats. In general, use GIF if the 
artwork has large areas of solid color and no blending of colors, and use JPEG for photographic 
images or images with a large tonal range.  For example, a picture of a blue sky with clouds looks 
“posterized” when saved as a GIF image. All the different shades of blue are mapped to only a few 
colors. GIF images are saved in 8-bit color mode, which means that only 256 colors can be 
represented. (Actually for the Web, only 216 colors are used, which makes the problem even 
worse.) JPEG saves the image in 24-bit mode, retaining all the colors. 
 
GIF files tend to load more quickly and have more optimization options. If you are working with a 
graphic that can be saved as either a GIF or JPEG file, choose GIF whenever possible. 
 
You can use transparency to mask the background of a graphic. Sometimes the Transparency 
option doesn’t  work, so be sure to test your pages on as many machines and browsers as possible.  
Interlacing is a method of defining the way the image is displayed in the browser. Interlacing 
displays every other pixel on every other line and then goes back and repeats the process, filling in 
areas not already displayed. Without interlacing, the graphic is “painted” on the screen line by line, 
starting at the top of the image. Interlacing increases the file size slightly, but its advantage is that 
it provides a visual clue to the user that something is happening. 
 
 
PLACING GRAPHICS ON THE PAGE 
 
Dreamweaver lets you choose how it references images: with document-relative or site-root-
relative references. With document-relative referencing, Dreamweaver constructs the path to the 
image based on the relative location of your HTML document to the graphics file. Site-root-
relative referencing constructs the path to the image based on the relative location of your HTML 
document to your site root. 
 
Generally, you should use document-relative links and paths. If you have an extremely large site or 
plan to move pages frequently within the server, you might want to use site-root-relative 
referencing. Site-root-relative references for images appear only on the server—they are not 
displayed locally. 
 
Until you save your file, Dreamweaver has no way to create the reference. You should always save 
yourdocument before you insert graphics. If you don’t, Dreamweaver displays an alert box and 
then fixes the file name path when you do save the Dreamweaver file. 
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To Insert a graphic using the Objects panel: 
 

1. Create a new file and save it as travel_log.htm in the DW4_WebDesign folder.  Use 

Compass Extreme Adventures as the document title. 

2. In the Page Properties dialog box, change the background color to #006699 and the 

default font color to #FFFFFF. 

3. Position the insertion point on the first line of the document.  

4.  Click Image on the Common Objects panel or choose Insert > Image in the menu to 

insert a graphic on the page.  

5. The Select Image Source dialog box opens, as shown in Figure 2-2. 

Figure 2-2 
 

6. If the Preview Image is not selected, select it to see a thumbnail of the images you click. 

7. Locate the image banner_head.gif in the image folder. 

8. From the Relative To menu area, choose Document. 

9. Click O.K. 

Note:  If your image is not located in the same folder as your files, a dialog box will 
appear informing you that your file is outside of the root folder and if you would like to 
copy the file.  Click YES.  Then Click the Save button to copy the file into your root 
folder.   

10. The document file name travel_log.html appears to the right of the menu. 

 
To center a graphic and add Alt text: 
The Alt option lets you specify text to be displayed on browsers when graphics can’t be displayed. 
This is a nice feature to add to all graphics that are critical to users for navigation. If users have 
graphic display disabled or are using a text-only browser, at least they can see some of the 
information they are missing. People with vision disabilities use a reader that speaks the Alt tags 
along with the text on a Web page. The Alt text is displayed briefly when the user moves the 
pointer over the graphic.  
 



 

 

1. Select the image if it is not already selected 

2. Type banner graphic in the Alt text box. Located in the property inspector to the right 

3. In the Property inspector, click the Align Center icon. If you don’t see the Align Center 

icon, click the expander arrow at the bottom right of the Inspector, as shown in Figure 2-3 

 
Figure 2-3 

Align Icons Expander 
Arrow

4. Below the banner graphic, type My Diving Travel Log. Make this text an italic heading 2, 

using the Verdana font, and left-align it. 

5. Position the insertion point on the next line and change the line to a paragraph format. 

6. Insert the diver.jpg image located in your image folder into your travel_log.html file. 

7. Type the text “diver graphic” in the Alt text box as shown in Figure 2-4. 

 

8. Press the enter key to accept your input. 

 

Figure 2-4 

To wrap text around an image: 
 

1. Minimize your Dreamweaver window and open the file diving.txt in the DW_Part 2 

folder 

2. Select and Copy the entire text. 

3. Select your travel_log.htm file, Paste the copied text to the right of the diver graphic.  

4. To make the graphic align to the left of the text, Select the diver graphic. 

5. In the Property inspector, choose Left from the Align pop-up menu, as shown in  

Figure 2-5.  The text moves up and wraps around the diver graphic.  This means the 

   graphic is left align to the text. 
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Figure 2-5 
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6. Insert the fish.gif image to a new line after the body text  

7. Position the insertion point after the fish graphic and type “Check out some of the fish we 

saw”. 

8. Align the text to the middle of the image by clicking the Align button previously mention 

and select middle. 

9. Save the file and preview it in the browser. 

 
IMAGE ALIGNMENT OPTIONS 
You need to understand how the alignment options work. The following seven options work well 
for aligning a single line of text near a graphic. As you saw earlier, they don’t work for wrapping 
multiple lines around a graphic (use Left or Right instead). Here’s what happens when you use the 
Align pop-up menu: 
 

Baseline: Aligns the bottom of the image with the baseline of the text line. 

Top: Aligns the image with the top of the tallest item in the line. 

Middle: Aligns the baseline of the text line with the middle of the image. 

Bottom: Identical to Baseline. 

Text Top: Does what many people think Top should do, which is to align the image with 

the top of the tallest text in the line (this is usually, but not always, the same  

as Top). 

Absolute Middle: Aligns the middle of the text line with the middle of the image. 

Absolute Bottom: Aligns the bottom of the image with the bottom of the text line. 

 
 
MODIFYING THE SPACE AND ADDING A BORDER AROUND IMAGES 
When you use an Align option to wrap text around graphics, you’ll probably want to adjust the 
space around the image as well. You can do this in the Property inspector. 
 
 
To add space and a border around an image: 
 
1. Select the diver image 

2. In the Property inspector, type 15 in the H Space text box. 

This creates 15 pixels of space on both the left and right sides of the image. You cannot add 

space on only one side. 

3. Type 2 in the V Space text box. 

This creates 2 pixels of space at both the top and bottom of the image. 
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4. In the Border text box located on the right of the Property inspector, type 2. 

A 2-pixel border is added to the diver image. The border color is always the same as the default 

text color specified in the Page Properties dialog box. 

5. Select the fish graphic and add a 2-pixel border to it. 

6. In the Property inspector, type 15 in the H Space text box.   

The graphic and text move apart. 

7. From the Align pop-up menu, choose Middle. 

The text is aligned to the middle of the graphic. 

8.  Save the file and preview it in the browser. 

 
 
CREATING LINKS 
HTML’s power comes from its capability to link regions of text and images to other documents. 
The browser highlights these regions (usually with color or underlines) to indicate that they are 
hypertext links. They are often called hyperlinks, or simply links.  
 
A link in HTML has two parts: the name of the file (or URL of the file) to which you want to link 
and the text or graphic that serves as the clickable link on the page. When the user clicks the link, 
the browser uses the path of the link to jump to the linked document. In some browsers, the path of 
the link is displayed in the status area of the browser window (the bottom-left part of the window) 
when the pointer is positioned over the link. 
 
 
Creating a Link to a Document: 
 

1. Open the welcome.html file in your DW_Part 2 folder. 

2. In the Document window, select the word “Surfing” under the Featured Tips Area. 

3. In the Property inspector, click the folder icon to the right of the Link text box. 

4. The Select File dialog box opens. 

5. Locate the file surfing.html and click to select it. 

6. The file name surfing.html appears in the Link text box. 

7. Save the file and preview it in the browser. 

8. Repeat steps 2 through 4 to link the word “Diving” to diving.html, the words “Mountain 

Biking” to biking.html, and the word “Rafting” to rafting.html. 

9. Save the file and preview it in the browser. 
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Creating a Link to an External Site: 
Hypertext links can “jump” the user to another document within the current Web site or to a page 
at another Web site. 
 
 

1. In the Document window, select the graphic at the bottom of the page. 

2. In the Property inspector, type http://www.australia.com in the Link text box, as shown 

in Figure 2-6. You must type the complete URL. 

Hint: If the URL is long or complex, you can go to that site in your browser and copy and 
paste the URL into the text box. 
 
3. Save the file and preview it in the browser. 

 

Figure 2-6 
 
 

 
TARGETING A LINK 
When you link to a page, the linked page replaces the current browser page. Sometimes, however, 
you may want to display the browser page in a new location or window. For example, if you link 
to a site outside your site, you have just led your users out of your pages. If they haven’t 
bookmarked your URL, users may not remember how to return to your pages. If your outside links 
open a new browser window, your page remains in the original window. 
 
To target a link: 

1. With the bottom graphic still selected, choose _blank, from the Property inspector’s Target 

pop-up menu, as shown in Figure 2-7 

 Figure 2-7 

Link Text Box 

2. Save the file and preview it in the browser. 

3. When you click the bottom graphic, the resulting page opens in a new browser window. 

4. In Dreamweaver, you can easily change the location where the linked page is displayed by 

using the following targets. 
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Note:  Targets other than _blank work only when you create frames for your page. 

_blank: Loads the linked document in a new, unnamed browser window. 

_parent: Loads the linked document in the parent frameset or window of the frame 
that contains the link.  If the frame containing the link is not nested, the linked 
document is loaded into the full browser window. 

_self: Loads the linked document in the same frame or window as the link. This 
target is implied, so you usually don’t have to specify it. 

_top: Loads the linked document in the full browser window, thereby removing all 
frames. 

Note: Use caution when opening new browser windows. New windows impose extra RAM 
requirements on the user’s computer as each window is opened. 
 
LINKING TO NAMED ANCHORS 
When a document is long or has many sections, you might want to create a link that jumps the user 
to a specific place in the document. This eliminates the tedium of scrolling through the document. 
To do this, you must create a named position—an anchor—that you can reference as the link.  
 
To Insert an Anchor (Named Position): 

1. Open the file trips.htm.  

2. Position the insertion point before the heading “Hawaii – Multisport” at the bottom of the 

document. 

3. Make sure you haven’t positioned the insertion point in the top navigation area. 

4. Choose Invisibles from the Objects panel’s Options menu. Click Named Anchor or 

choose Insert > invisible Tags > Named Anchor from the menu to insert an anchor  

(the place to jump to). 

5. The Insert Named Anchor dialog box opens, as shown below in Figure 2-8. 

Figure 2-8 
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6. Type hawaii in the Anchor Name text box and then click OK. Don’t use spaces or special 

characters in the name.   

7. A yellow icon appears on the page to represent the anchor. 

 
Hint: If you can’t see the icon, make sure Invisible Elements is turned on by choosing  

     View > Visual Aids > Invisible Elements from the menu. 
 
To link to a named anchor: 

1. Select the text “Hawaii – Multisport” at the top of the document. 

2. In the Link text box of the Property inspector, type #hawaii. 

3. Make sure the name you type here is exactly the same as the anchor name. Anchor names 

are case sensitive. 

Note: You must type the number sign (#) before the anchor name in the Link text box. 

4. Save the file and preview it in the browser. 

 
To link by using the Point to File icon: 
The one area where HTML is case sensitive is in the naming of your anchors. If you name your 
anchor “top,” for example, and then type #Top in the Link text box, your link may not work 
consistently in all browsers. To avoid typing errors, you can use the Point to File icon located in 
the Property inspector (see Figure 2-9). 
 
 

1. Add another anchor before the Alaska Vacation heading and name the anchor Alaska. 
2. Select the words “Alaska Vacations” at the top of the document. 
3. Drag the Point to File icon and point to the Alaska anchor that you just created. Release 

the mouse button when you are directly over the anchor. 
4. The link is made. 
5. Using the Point to File icon, insert anchors and links for the remaining headings. 
6. Save your file and preview it in the browser. 
 

 
 
 

Figure 2-9 
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CONNECTING TO A REMOTE SITE 
 
In Lesson 1, you created a local site—that is, a folder on your hard drive to store all the folders and 
files needed for your site. You’ve been working in the local site, developing pages and testing 
links. For visitors to see your Web pages, however, you need to copy them to a remote site. 
Typically, the remote site is on a server specified by your Web administrator or client, but it could 
also be on a local network. 
 
After creating your local site, you choose which remote site to connect to and the attributes of that 
remote site.  
 
To set up a connection to a remote site: 
 
 1. Choose Site > Define Sites. 
 The Define Sites dialog box opens, as shown in Figure 2-10. 

Figure 2-10 
The Define Sites window. 

 
2. Select your site from the list and click Edit. 
 The Site Definition dialog box opens (see Figure 2-11). 

 
          Figure 2-11 

FTP settings in Site Definition dialog box. 
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 3. In the Category list on the left, select Remote Info. 
4. From the Access pop-up menu, select FTP. 
5. In the FTP Host box, enter faculty.sjcny.edu. 
6. In the Login box, enter your username.  (This name is provided to you when you have an 

account set up on the web server.) 
7. Enter your password. 
8. Click OK to save your site information. 
9. Click Done to close the Define Sites dialog box. 

 
The Site window displays the file and folder structure of your site. You use this window to copy 
your pages to the web server.    
 
To access the Site window and connect to the remote host: 
 

1. Choose Site > Open Site and select your site from the list. 
 The Site window opens, showing only your local files (see Figure 2-12). 

Figure 2-12 
The Site window. 
 

The default settings place your local files in the right pane of the Site window. When you connect 
to the remote site, the remote files appear in the left pane. 
 

2. Choose Site > Connect. 
You will be connected to the web server.  The remote host is shown in the left pane of the 
site window. (see Figure 2-13) 
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       Figure 2-13 
 

3. Click once on the root folder located in the local folder pane (right pane). 
4. Choose Site > Put. 

Your entire site will be copied onto the web server. (see Figure 2-14) 

         Figure 2-14 
 

5. Choose Site > Disconnect to disconnect from the remote site. 
6. To view your web site, start your web browser and type in the following url: 

www.sjcny.edu/~lastname   (replace lastname with your lastname) 
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